Skip to content
This repository was archived by the owner on Jan 30, 2021. It is now read-only.
This repository was archived by the owner on Jan 30, 2021. It is now read-only.

SOLVED: private_key_path file must exist: ~/.ssh/id_rsa #234

Description

I'm using the v2.0.0 on Windows 10.
I am following the steps in the current README.md, having now all az set up, logged in and environment variables set.

Now, using the sample/default Vagrantfile from the README for config.vm.box = 'azure' fails for me with this:

PS D:\_\vagrant\vagrant-azure> vagrant up --provider=azure
There are errors in the configuration of this machine. Please fix
the following errors and try again:

SSH:
* `private_key_path` file must exist: ~/.ssh/id_rsa

PS D:\_\vagrant\vagrant-azure>
  • Is there anything missing from the docs about the SSH private key and ~/.ssh/id_rsa path?
  • Is user supposed to ssh-keygen-generate it prior provisioning the VM? It is the host location, isn't it?

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions