Skip to content
This repository was archived by the owner on Nov 13, 2024. It is now read-only.
This repository was archived by the owner on Nov 13, 2024. It is now read-only.

[Bug] Canopy cannot find the index created #305

Description

@sfdrada

Is this a new bug?

  • I believe this is a new bug
  • I have searched the existing issues, and I could not find an existing issue for this bug

Current Behavior

canopy start --index-name test-name
Error: Failed to initialize Canopy server. Reason:
The index canopy--first-pinecone does not exist or was deleted. Please create it by calling knowledge_base.create_canopy_index() or running the canopy new command

Expected Behavior

Expected the canopy start command to initialize the Canopy server with the specified index name without errors.

Steps To Reproduce

In the Canopy virtual environment.
Using the config with specified index-name.
Run canopy start --index-name canopy--todd-sergio.
See error.

Relevant log output

No response

Environment

- **OS**:
- **Language version**:
- **Canopy version**:

Additional Context

i am not sure if there is a different way to reference this specific index, maybe by setting up a environment variable but setting the INDEX_NAME and PINECONE_ENVIRONMENT variables did not change it from asuming the default name. This index-name command did work however when upserting to the model which is why I was confused when it couldnt run to it

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    bugSomething isn't working

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions